Update: Curse of Dragon

Update to: Curse of Dragon

The current version of the platform cannot run in new mordern browsers. When it was developed it was fully compatible with IE6 and FF1.5-3.5. As there is no more development on the project, I will not be creating any patch for it.


Leave a Reply